Re: Kernel 2.4.4 - No Mouse?

Subject: Re: Kernel 2.4.4 - No Mouse?
From: Chris Ruprecht (
Date: Tue Apr 24 2001 - 10:34:00 MDT

OK - forget it - I copied the definitions from ./drivers/macintosh/mac_keyb.c into ./drivers/char/adbmouse.c and it seems to have worked.

However, this is not 'normal' ...


Chris Ruprecht
(972) 856-3891

>>> 04/24/01 11:26AM >>> Hi all,

I have made kernel 2.4.4 on my Pismo with the configuration found in .config from I went through 'make menuconfig' first to check on anything which I would do different and if there is some device which I have which is not enabled. Everything looks good, so I went ahead and made the kernel. After booting the kernel, I tried to get into X but I got stopped dead: no mouse. /dev/adbmouse is a nonexisting device. I compared .config from the 2.4.4 kernel with .config from the 2.2.17 kernel and there are differences concerning ADB devices. I switched the mouse on and now .drivers/char/adbmouse.c gets compiled and included into char.o but at the last stage of the make process, I get unresolved externals "adb_mouse_interrupt_hook", "adb_emulate_buttons", "adb_button2_keycode" and "adb_button3_keycode". I'm missing the definitions ind some module somewhere, how do I switch this on?

Best regards, Chris

-- Chris Ruprecht (972) 856-3891

This archive was generated by hypermail 2a24 : Tue Apr 24 2001 - 10:37:03 MDT