RE: eth0 not working with DHCP

Subject: RE: eth0 not working with DHCP
From: Larry Sampas (
Date: Fri Feb 09 2001 - 17:21:34 MST

I had the exact same problem on a powermac 9600 running 1.2.1

It picked up the IP address from the server OK (Win2K Server -- can't
help.), but then refused to acknowledge its address on the Internet. It just
didn't answer arp requests for its ethernet address when I was looking at it
with a sniffer. Even refused to answer traffic when I stuck static arp entry
on my Win2K machine.

I fixed it by going to a static IP -- it worked right away.

The only notes I found for DHCP issues were from SuSE at . Also mentions an
updated package for DHCP at .

SuSE seems a little better on the support than Yellow Dog, especially
considering they haven't been supporting PPC as long.

I haven't actually tried the DHCP client -- just sticking with the static IP
for now.

-----Original Message-----
From: Philip Good []
Sent: Friday, February 09, 2001 4:12 PM
Subject: Re: eth0 not working with DHCP

How are you configuring your eth0? By hand, linuxconf, netcfg? linuxconf
tends to be incomplete in this area (I've found).

Launch netcfg from the shell, deactivate the eth0, then re-activate
eth0, you should see some messages on the shell screen which may help.
Also, if you have access to the server running dhcpd, you could do:

tail -f /var/log/messages

and look for the DHCP reconnection.

Check to make sure that the Default Gateway under Routing is correct.
This got me one time, you don't get any errors but can't connect. Also,

/etc/rc.d/init.d/network restart

and see what you get.

Good luck

> Hi all,
> I have recently installed YDL on Mac 7500 - with no non-standard
> components - and have configured Ethernet port for DHCP. YDL is
> off the 1.2.1 CD with no updated RPMs
> When connected to the LAN with DHCP server I get IP address assigned,
> gateways and DNS server addresses configured correctly but am unable
> ping anything on network, nor can my Mac be pinged from elsewhere.
> Unsurprisingly, nothing else works over Ethernet either.
> Network card is OK - it works with MacOS and must have talked to the
> DHCP server under YDL to get the IP address etc. If I restart with no
> LAN then eth0 fails to init and I get no IP address which proves the
> address was assigned by connecting to DHCP server.
> Can anyone suggest how I diagnose/treat this ailment?
> Thanks.
> Paul.

Philip Good
Red Planet Development, Red Canyon Software, Good Chi Tai Chi

This archive was generated by hypermail 2a24 : Fri Feb 09 2001 - 17:22:12 MST