Re: XFree 4.0.1 rpms help

Subject: Re: XFree 4.0.1 rpms help
From: Black (
Date: Fri Jan 05 2001 - 12:45:21 MST

On Wed, 3 Jan 2001, Hollis R Blanchard wrote:

> On Wed, 3 Jan 2001, Black wrote:
> >
> > So, I just installed the 4.0.1 rpms that Hollis so thoughtfully put
> > together. When I tried to restart xfs when I was done, it failed, telling
> > me that was missing. So, I went out to rpmfind to figure
> > out what should be supplying it. It looks like XFree86-libs-* should be
> > supplying it. I did an rpm -qpl XFree86-libs-4.0.1-0.43b.ppc.rpm and it
> > doesn't appear to be present. Am I missing something here? I'd appreciate
> > any help.
> /usr/X11R6/lib/ is supplied by
> XFree86-libs-4.0.1-0.43b. I certainly hope you upgraded XFree86-libs when
> you installed...

I looked again, and just to make me look foolish, it was indeed there in
XFree86-libs-4.0.1-0.43b, however, at the risk of doing this to myself
again, it _doesn't_ seem that any of the GLU or GLUT libraries that were
present before are present in XFree86-libs-4.0.1-0.43b (i.e. when I did an
upgrade from the previous version, it told me I had failed dependancies
because of it (the ones I remember were for xscreensaver and xmms...). It
didn't look like these were critical to getting X back online, so I just
--nodeps the upgrade and moved on.

I ran Xautoconfig4 (the latest version) and then edited the XF86Config-4
file (mostly updateing the bus ID and changing the driver to ati). I did a
startx and it failed. Apperently the font path of unix:\-1 (or whatever
that ends up being) wasn't liked, so I uncommented the list of possible
font paths. This time it didn't seem to fail, but I got garbage. That is
to say, the machine beeped once and then put like three horizontal colored
bars on my screen. Now, I have never managed to kill X the way you are
supposed to (ctrl-alt-del ?), possibly because I am on a powerbook and
don't actually have a distinct delete key (just a backspace), so I ended
up having to just pull the plug and pop the battery, which is not
something I really enjoy doing... As a result, the log file never got
finished, so it, of course, wasn't there when I went looking for it to see
if it could yield any information.

If anyone could help me here, I would really appreciate it. I am starting
to feel like I am just missing something basic somewhere, I don't know why
this should be this hard.

my setup:
266 mHz 1998 G3 powerbook, with linux running from a removable hard drive
(I have yet to have any problems that looked like the result of being on a
removable drive...)
I am running the 2.2.17-0.6.1 kernel from the CS 1.2.1 update.

At the moment, I have the no video driver box checked in bootx because
everytime I uncheck it I get two inch wide vertical bars every three
inches that take their color from anything in the vertical plane (i.e. if
the bar crosses white text on the black background, it smears the white
the entire height of the screen, top to bottom).

I would appreciate any suggestions that would get X-windows running on my
machine again.


This archive was generated by hypermail 2a24 : Fri Jan 05 2001 - 12:45:25 MST