Re: Ethernet pain

Subject: Re: Ethernet pain
From: Elliott (
Date: Mon Jan 08 2001 - 19:35:28 MST

oh yeah, the exact error given when pump -i eth1 is issued:
eth1: media is 100Mb/s
eth1: media is unconnected, link down or incompatable connection.
This is the same if I use the new intel macscnse card or the older
Digital chip card.
I guess I just need to find a way to slow this sucker down.

Elliott wrote:

> Ok. First off, I would like to thank all the helpfull people on this
> list. I couldn't do this alone.
> Seccond off, I haven't exactly done it yet. Let me recap a bit, and
> tell y'all about the recent developments.
> On booting ydl, eth0 and eth1 are defined for me as to which interface
> is which hardware device. Fine, except what it picks for eth0 is the
> on-board ethernet that doesn't work. eth1 is an ethernet card (tulip
> driver). ifup eth1 doesn't do anyting ( here's what I get: "usage:
> ifup <device name>") as if its not even recognized as a valid device,
> even though its listed in /etc/conf.modules plain as day.
> Linuxconf is not working to my knowledge - I set up the card in
> linuxconf as eth1 (figuring that setting it otherwies wouldn't be a
> good idea due to the fact that the kernel decides ahead of time on
> boot up who is who), and when I activate the changes on quit, it gives
> me errors about not being able to start the network. Thats expected,
> but I guess it doesn't write the configuration files either, because
> if I go back into linuxconf, everything is either blank or default.
> So, I would like to know everything that linuxconf modifies, or should
> modify for a network hardware setup.
> Anyway, ifup eth1 doesn't work, as allready stated. However, ifconfig
> eth1 up does do something a little different. Well, when I type
> ifconfig eth1 or whatever, that is. After typing that,
> everything seems to go allright, at first, anyway. ifconfig eth1 lists
> the ethernet card with its hardware address as well as an ip address.
> But I get these messages which soon fill up the screen "network format
> not supported..... using 100mbts/sec data rate...." or someting like
> that. (I can't exactly paste the message into the email.....)
> Basically, I think the card can opperate at either 10baseT or
> 100baseT. Well, my entire network (hub, router, etc) is 10baseT (can't
> afford a switch...). So, I thought I would tell the card to operate at
> 10baseT. The man page for ifconfig isn't as good as I would like it to
> be under the "media type" heading. But anyway, typing ifconfig eth1 up
> media 10baseT doesn't work. I get some sort of "invalid
> instruction" message. The command goes in fine. (it might have been
> "ifconfig eth1 up type 10baseT" I can't remember). I
> just get some wierd message basically saying that my card doesn't
> support that kind of instruction.
> I thought I would go for a different approach now. So I tried fooling
> around with pump. There isn't a /etc/pump.conf file on my system, or
> any of the other red hat systems on my network using dhcp protocall.
> So I didn't know how to format that, so I just didn't do one. running
> pump -i eth1 doesn't work. I think it just hung there until I hit
> ctrl-c for a command prompt.
> Well, I was pretty upset after all that. So I went arround ripping out
> ethernet cards from other computers (a 3com590, and a 3com 3c905
> [couldn't find drivers for this one]). None of the cards I poped in my
> rev. A G3 worked. Infact, the kernel only detected the bulit in
> ethernet on boot up. running a lspci turned up the card (3 com network
> interface or somthing, it said). But I guess that's not descriptive
> enough or something.
> Placing the origional ethernet card back into the macintosh was really
> upsetting - the card wouldn't work from mac os9.0.4. Ouch! Infacti,
> the tcp/ip control panel listed my ip as or something
> (thats the misterious mac os phantom dhcp server, so I hear). And,
> upon looking at my hub, I discovered that the "activity" light over
> the ethernet port of this computer was blinking kinda like when you
> ping -f a host (ping flood). The collision light was rather frequent,
> as well as the partition on the adjcent hub when I messed arround
> plugging the cord into other hubs and such. I'm guessing that linux
> got the card stuck in 100baseT mode or something. I rebooted several
> times (no effect) and even removed the card for 10 minutes and placed
> it back (turned off the computer for this, of course). Still stuck in
> 100baseT mode, I think. I turned off the computer in discuss. The next
> day, I went out and bought another ethernet card. Its an Macsense fast
> ethernet adapter FE-511. Its got an intel chipset. I looked into
> buying a single speed 10baseT card, but I couldn't recognize any of
> the chip sets (I was limited to cards that were pci as well as mac os
> 9 compatable, so I didn't have much to choose from). Anyway, I got
> home, and the existing ethernet card worked in mac os 9. Still no
> ethernet in ydl. I'm going to try the macsense card tonight and see if
> the yellow dog likes it. I hope it does.
> Any help would be great - I'm stuck. But I do think that the tulip
> card is recognized and that if I can just configure it right it will
> work. Well, I hope so, anyway. Thanks!
> PS: I got the newest X release for ppc, and its great!

This archive was generated by hypermail 2a24 : Mon Jan 08 2001 - 19:35:21 MST