FW: Eth0 not responding

Subject: FW: Eth0 not responding
From: Vanja Bucic (vanjab@UDel.Edu)
Date: Wed Jan 17 2001 - 13:32:10 MST

Once again... ;-)

    I have had spurious problems with my Ethernet. Every couple of weeks it
just goes dead. If I do ifconfig, it says that eth0 is up and running, but I
have no Ethernet access. FTP, ping, Apache, sendmail, they are all dead. My
only choice was to restart the network. ifconfig up/down did not work
(parameters are not being read from /etc default files). I tried
..rc.d/../S10network restart , and it did restart all network services, but
DNS lookup would fail (explicit IP's worked). Then I used the control-panel
to restart eth0 service, and that worked fine.
It is a rare event (once in a couple of weeks or even months), but it is
annoying. People ask me what happened, why is the server down, power failure
or what? It is kind of embarrassing to answer like 'Oh, I just need to
restart the network and slay a goat in attempt to please Ethernet gods'.

Is this something that is known to happen with the BMAC driver?
I could always put up some cron job to reset the Ethernet, but that is quite
ungraceful, plus I know of no safe command-line way to reset the eth0

Suggestions welcomed.

Vanja Bucic
Bartol Research Institute

Machine info:
All-in-one G3 @ 233MHz
30G DiamondMax HD
CD-Rom, ZIP drive
Original built-in Ethernet
Standard YD1.2.1 kernel and drivers

This archive was generated by hypermail 2a24 : Wed Jan 17 2001 - 13:32:35 MST