drive initialization problem

Subject: drive initialization problem
From: antadam (
Date: Wed Jan 24 2001 - 07:19:38 MST

i have a 60 gig maxtor drive that was formatted hfs a while back so i could
mount it as mount -t hfs /dev/hda8 /mnt/hd60 and it'd mount fine, however, i
want to run it as an ftp drive so i gotta format it to ext2 to do that. so i
went into mac os to initialize it for 1 2 gig mac hfs partition then a unix
one (i had to do it to install ydl b/c pdisk didn't want to work for some
reason). so anyways, it wouldn't mount obviously. i ran pdisk w/the table
looking like this......
/sbin/disk /dev/hda

1: apple_partition_map Apple 63 @ 1
2: apple_driver_ATA* macintosh 54 @ 64
3: apple_driver_ATA* macintosh
4: apple_fwdriver macintiosh
5: apple_driver_iokit macintosh
6: apple_patches patch partition
7: apple_hfs untitled
8: apple_unix_svr2 unreserved 1
9: apple_free extra

so i do delete partition 8, create partition 8 from the end of partition 7 to
the end of the drive, write the map, and quit. when i go to do mount
/dev/hda8 /mnt/hd60 i get mount: you must specify the filesystem type
so i do mount -t ext2 /dev/hda8 /mnt/hd60 and i get
mount: wrong fs type, bad option, bad superblock on /dev/hda8, or too many
mounted file systems
nothing's mounted in the /mnt/hd60 folder. any suggestions?
i ran /sbin/mke2fs and got an error (i was suggested to run it).
this is on a blue and white g3 450, 256 ram, running off a 10 gig scsi (the
60 gig drive ran linux at one point on a 20 gig partition so i know it can be
partitioned), cs 1.2.1 kernel 2.2.17
any suggestions would be appreciated

This archive was generated by hypermail 2a24 : Wed Jan 24 2001 - 12:20:46 MST