Re: Fixed it (was re: non-root user startx problem)

Subject: Re: Fixed it (was re: non-root user startx problem)
From: Jim Cole (
Date: Sun Jul 09 2000 - 19:38:45 MDT

Hi - Actually your XF68_FBDev should *not* be setuid. This has the
potential to create some security problems, which may or may not be
an issue depending on how your system is used. Use of a setuid server
was phased out with the introduction of 3.3.2. There is more info on
this subject at

Instead of a setuid server, you should have a binary named Xwrapper
(in /usr/X11R6/bin) that is setuid. Perhaps Xwrapper was messed up
or not installed during your upgrade?


Sam Moore's bits of Sun, 9 Jul 2000 translated to:

>OK, I figured out I had to turn on the setuid bit on the binary XF68_FBDev at
>/usr/X11R6/bin to get this to work.
>Just curious why no one else had this problem...
>On 7/8/00 at 4:11 PM, (Sam Moore) wrote:
>> Didn't get any response on this, so I thought I'd try again...
>> > Hi folks. This is probably real simple, but here goes...
>> > After upgrading to CS 1.2, I can't startx as anybody but root any more.
>> > I've read the instructions at
>> >
>> > which refer to "Xpmac-6.3" or "Xpmac-6.1"
>> > I don't have either of these at /usr/bin/X11, just a binary called "Xpmac"
>> > (actually it lives in /usr/X11R6/bin/, with a link back to /usr/bin). I've
>> > permissions on this binary to 4511 as instructed, so that the owner "root"
>> has
>> > read and exec privileges, and the group "users" and "others" have exec
>> > privileges only. SetUID is on.
>> > Nonetheless, when I try to startx as anyone but root I get:
>> >
>> > Authentication failed - cannot start X server
>> > Perhaps you do not have console ownership?
>> > ::long pause::
>> > xinit: Connection refused (errno 111): unable to connect to X server
>> > xinit: No such process (errno 3): Server error.
>> >
>> > Any clues appreciated.
>> > thanks
>> >

This archive was generated by hypermail 2a24 : Sun Jul 09 2000 - 19:25:01 MDT