BootX doesn't see my hard disk and yaboot configuration problem (Help!)

Subject: BootX doesn't see my hard disk and yaboot configuration problem (Help!)
From: Riccardo Gusso (
Date: Fri Jun 09 2000 - 08:57:35 MDT

This is a rather strange problem: yesterday evening I tried to install
YellowDog CS 1.2 on a friend of mine's iMac. He had changed the original
4 Gb hd with a larger 13 Gb one. First we copied the YellowDog CD on a
hfs partition created to exchange files from Mac OS to Linux and started
the installer usign BootX. It started ok, but when I chose Hard Disk as
place where to find the files for installation it seemed not to see ANY
partion (or any device, Linux speaking) on the disk. So I retried to
start the installation directly from the cd, that is booting the imac
from the YellowDod cd, that means, I suppose, to use yaboot instead, and
everything worked. So I thought that I had to configure properly yaboot
to start Linux (I tried again with BootX but, as I was expecting, I got
kernel panic because Linux couldn't find root device).
I did the following steps (following the not so clear instructions of
YellowDog Guide):
I put yaboot.conf, yaboot.tbxi and vmlinux in the system folder of MacOs
partition); I edited yaboot.conf to match my partion configuration. Then
I go into Open firmware to change the Boot device variable using "setenv
boot-device hd:7, \\yaboot.tbxi", but unfortunately I'm using an Italian
keyboard and I can't find the "\" anywhere !!!!!! so I could not to
complete the command.
Is there any solution???


          "And what can I tell you my brother, my killer 
           What can I possibly say? 
           I guess that I miss you, I guess I forgive you 
           I'm glad you stood in my way."

L. Cohen, "Famous blue raincoat"

This archive was generated by hypermail 2a24 : Fri Jun 09 2000 - 09:01:36 MDT