The Continuing Installation Saga. Pram zap hosed open firmware.

Subject: The Continuing Installation Saga. Pram zap hosed open firmware.
From: William K. Gibson (
Date: Sat Mar 03 2001 - 20:08:41 MST

For all those who helped with my TiG4 intallation- many thanks. But I must
enlist your wisdom again.

In trying to get MOL to work I used TechTool 1.2.1 to zap the PRAM, hoping
it would help.

Unfortunately after I did this my bootscript would not work. Ok, I think,
I'll restore the PRAM I zapped and everything will be fine. Nope, it still
didn't work.

Ok, I think, I'll boot into open firmware and reset the boot-device. But to
my surprise, open firmware would not work correctly anymore. When I tried

    setenv boot-device hd:10,\\yaboot

I got an 'ok' back, but when I typed


I got another 'ok' and the prompt number changed. Kinda like this

    0 > boot ok
    2 >

Further boot calls simply added two to the prompt number

    0 > boot ok
    2 >
    2 > boot ok
    4 >
    4 > boot ok
    6 >
    6 > boot ok
    8 >

Wierd. I tried to boot off the hard drive directly.

    boot hd:10,\\yaboot

Open firmware complained like this:

    hd:10,\\yaboot, unknown word

I tried this
    boot hd
    hd, unknown word

I tried this:

    boot cd

So, it seems to have lost the syntax for 'hd' and also the 'boot' command
does not seem to function properly.

So I tried to boot off the Yellowdog install CD

    setenv boot-device cd:,\\yaboot

That worked. But, unfortunately, the install CD boots to a blank screen.

Really though, that's beside the point. I don't want to boot off the CD, I
want to boot off my linux install on the hard drive.

I can get my mac OS to boot with 'mac-boot' if I set the boot-device to
anything other than the CD- but I know that this is a default behavior (when
I do it a folder comes up with a blinking question mark and then it finds my
MacOS hard drive).

Anyway, what have I done to my open firmware? Is there a install package I
can get to restore it to its previous state? Has anyone even heard of this
problem before?

Many thanks if you took the time to read this one.

--William K. Gibson
1stDesk Systems

This archive was generated by hypermail 2a24 : Wed Mar 21 2001 - 08:28:44 MST