Re: Linux Networking Hell

Subject: Re: Linux Networking Hell
From: Bryn Hughes (
Date: Thu Mar 22 2001 - 16:33:05 MST

I'm using mine with 3 NICs, no problems. 2 Tulip and one GMAC (PM G4
internal).... The GMAC drivers are a little flakey, but that's got
nothing to do with YDL. The Tulip drivers work perfectly.

I haven't yet found a way to force the link negotiation to anything,
as far as I can tell the only way to do this is to compile your NIC
drivers as modules and then pass parameters to them? I've been told
this, but never how to actually DO it, and of course there's nothing
out there that I can find that tells you how.

I have seen pics of ifconfig on people's systems showing info like
that, so I know someone out there is working on it...

And yes, the system does decide what eth0, eth1 etc will refer to,
but it's always the same every time. Onboard is eth0, first PCI NIC
will be eth1, and so on. Same as on the Mac side where the onboard
will be "Ethernet" and then any additional cards will be something
like "Ethernet Slot B1" and so on.

If you haven't checked the config for your video card drivers, you
may well find you haven't set it up to use them. I also know the
stock kernel with YDL doesn't have support for everything, but yup
can take care of that pretty quickly. I really don't know why your
mouse didn't work, mine works fine.


>Hey, did you ever get that to work? I had similar problems. I even
>purchased another ethernet card, and it wouldn't work either. I
>think yellowdog may have a bit of a problem supporting two ethernet
>cards... the Kernel seams to sort of decide which card is eth0 and
>eth1 on startup, which I found annoying. And, when I finally did get
>something to kinda work, the card refused to slow down to
>10mbit/sec. (it workes fine in OS9, soon to be OSX). Well, I gave up
>on ydl linux all together, because networking was the main reason I
>got it. Not to mention the fact that my sound didn't work, I
>couldn't use both of my monitors (not even the on-board ati - only
>the ati orion card), my usb mouse didn't work, and my FireWire cdrw
>drive will never work under linux..... oh well... I don't have much
>patients with this stuff. Let me know if you get that network setup.
>Maybe i'll stop complaining and get to work on my box.
>Barry Sparenborg wrote:
>>Thanks, I'll try this weekend. Too damned frustrated now. Just lost my
>>raid device also. Ugh!!!!!!!!!!!!!
>> -----Original Message-----
>> From: cdowns []
>> Sent: Monday, March 12, 2001 1:13 PM
>> To:
>> Subject: Re: Linux Networking Hell
>> Barry Sparenborg wrote:
>> > on 3/12/2001 8:53 AM, cdowns at wrote:
>> >
>> > > Barry Sparenborg wrote:
>> > >
>> > >> Well I have tried just about everything that I know (which
>>isn't saying
>> > >> much) to get my Farallon Fast EtherTX 10-100 card working in
>>linux. Works
>> > >> fine in Mac OS. Latest attempt was to compile the de4x5 into
>>the kernel and
>> > >> then as a module. Also did the same with Tulip. When i try
>>insmod to load
>> > >> the module i get the device busy all the time. I can ifup eth1
>>and it seems
>> > >> the inteface is up and i can pin it from the machine i am
>>working on but not
>> > >> from any other machine on my network plus i cannot ping any
>>other machine
>> > >> from it. I have tried the card in all of the slots same
>> > >>
>> > >> Anybody got any words of advise?
>> > >>
>> > >> I am running a stock Powermac 8500av with YDL CS 1.2.1 kernel
>>version 2.2.17
>> > >>
>> > >> Thanks,
>> > >>
>> > >> Barry
>> > >
>> > > thats becuse you need the latest tulip drivers.... the one
>>supplied (by
>> > > default) does not work correctly anymore with most of the new
>>chipsets. i
>> > > would
>> > > give you the link to my server but ofcourse mediaone is having
>>issues today
>> > > AGAIN ~! man... ...
>> > >
>> > > anyway. and i cant remeber the primary site to them but im sure
>>you can get
>> > > that.
>> > >
>> > > good luck
>> > > -D
>> > >
>> > >
>> > When I find the current driver, is there a how to or something
>>that will
>> > instruct me on the installation process?
>> >
>> > thanks,
>> >
>> > Barry.
>> here i got my home server back up, ( mediaone is GAY ) anyway heres
>>the link with
>> a little how to i wrote :
>> you will see the tulip.0-92.tar file. grab that and run the
>> file i
>> created. just make sure it fits you modules dir. you should not have
>>to recompile
>> your kernel ass this little script does it for you.
>> good luck
>> -D

This archive was generated by hypermail 2a24 : Thu Mar 22 2001 - 16:34:14 MST