install problems on G4 cube

Subject: install problems on G4 cube
From: Charles Lepple (
Date: Tue Mar 27 2001 - 07:58:22 MST

I've been having some problems installing Champion Server 1.2.1 on my G4
cube (purchased this month - I wonder if the hardware is newer than what
the kernel supports). Any help (or pointers to a FAQ list that I might have
missed) would be greatly appreciated.

(Please excuse the basic nature of these questions - this is my first Mac,
and the last time I played with Linux/PPC was with an embedded 603e board.)

Things I tried:

* booting the CS-1.2.1 install CD directly

I grabbed the .iso off of the web and burned it on a wintel machine (Apple
only ships a very basic CD burning tool with MacOS 9.1... bleh). I booted
the machine, held down 'c' and got a gray screen. I left it for a while,
pressed a few keys, and gave up on that because I wasn't even hearing
anything from the CD drive.

* copying yaboot to the system folder, booting into OF and doing 'boot

this works if I choose the install-novideo option. I have the entry-level
ATI graphics card and an ADC monitor. I'm not at home now, so I don't
recall the diagnostic messages, but I vaguely recall that something
kernel-wise didn't recognize that specific chip ID.

* running the second-stage install from the CD-ROM

After fooling around with this one for a while, I found out that the kernel
is locking up right around the first time that it tries to access the CD
directly (as opposed to yaboot loading the ramdisk image... am I getting
this right? Is this pretty similar to what LILO does on a PC?). There is a
distinct lack of kernel messages (even if I quickly switch to the kernel
message VT), the cursor stops blinking, and the keyboard becomes

* running the second-stage install over a local network

I popped the CD into an intel linux box and made it available via the web
server. The G4 was able to get a DHCP lease (although the installer DHCP
code gets confused if the DHCP server acks an existing lease... my DHCP
server (ISC dhcpd 2.x) was giving it the same IP address as under MacOS,
and occasionally I had to try twice to get a lease ). However, kernel
messages indicate that the PHY interface (ID 0x1378e1) is unknown (kernel
version 2.2.17-0.6.1). It also misdetects the link as 100BaseTX, full
duplex (it's 10BaseT, half duplex... takes longer to move CD images around
than it does to burn them :-/ ). This wouldn't be a big deal, except that
once the transfer seems to get rolling, the G4 seems to take a nap. tcpdump
shows a burst of packets every minute or two, and I can only ping the
machine occasionally.

* installing from the local hard drive

It's been a while since I played with the hfs mount support in linux... so
I have no clue what path to type in. I'm fairly certain I guessed the MacOS
device name (the one that didn't fail when the installer tried to mount it)
but I tried just about every combination of volume name and directory that
I could think of. (The files were in the top-level directory, not on the
desktop... figured that would be easier.)

Has anyone else seen this? (I envy you people who are mailing the list
about such features as audio support on the Cube :-P )

One last question: is there a document describing the syntax of the OF boot
paths? I've seen a bunch of clarifications about "hd:,\\" vs. "hd:,\\\\"
and I'm curious as to where you folks found this stuff out.


Charles Lepple <>

This archive was generated by hypermail 2a24 : Tue Mar 27 2001 - 08:01:08 MST