Re: Double Net cards?

Subject: Re: Double Net cards?
From: Vanja Bucic (vanjab@UDel.Edu)
Date: Fri Mar 30 2001 - 16:19:11 MST

Here is the ifconfig output:

eth0 Link encap:Ethernet HWaddr 00:05:02:AD:D9:22
           inet addr: Bcast:
           RX packets:10870 errors:8 dropped:8 overruns:0 frame:8
           TX packets:2152 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:100
           Interrupt:42 Base address:0x1000

eth1 Link encap:Ethernet HWaddr 00:00:C5:53:B4:A1
           inet addr: Bcast:
           RX packets:393 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:100
           Interrupt:24 Base address:0x400

lo Link encap:Local Loopback
           inet addr: Mask:
           UP LOOPBACK RUNNING MTU:3924 Metric:1
           RX packets:420 errors:0 dropped:0 overruns:0 frame:0
           TX packets:420 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:0

here is netstat -rn output:

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt
Iface UH 0 0 0
eth1 UH 0 0 0
eth0 U 0 0 0
eth0 U 0 0 0
eth1 U 0 0 0
lo UG 0 0 0
eth1 UG 0 0 0

I tried the card from the mac side and it works.
Also doing 'telnet' (eth1) will connect me to the eth0
interface. Everything seems to be going to eth0...

I don't know what else to check...

On Friday, March 30, 2001, at 06:05 , Bryn Hughes wrote:

> Hi there,
> First of all, go to your /etc/sysconfig/network file and make sure that
> DEFAULT_GATEWAY=eth1 (if that's what you want)
> Secondly, take a look at the output from /sbin/route. This will tell
> you what your box is trying to do.
> If you don't want to use eth0 at all, go to
> /etc/sysconfig/network-scripts and delete (or rename) ifcfg-eth0. Or
> alternatively open that file and change ONBOOT="yes" to ONBOOT="no".
> Bryn
>> Hi,
>> I just installed an additional net card into my AllInOne Mac.
>> Everything
>> worked fine, or so it looked like.
>> Problem: all network traffic defaults to eth0 built-in BMAC
>> ethernet
>> card. I don't want to use this buggy piece of *. That is why I bought
>> Farallon FastEther 10/100 TX card. How do I bypass the eth0?
>> I tried to just unplug the eth0 cable, but that would also render
>> the
>> eth1 unusable. The packets would come in eth1, but could not go out
>> (probably trying to go out through eth0).
>> How can I make these two cards self sufficient so eth1 doesn't
>> depend on
>> eth0? I want to be able to telnet into this computer in case one of the
>> cards dies (as BMAC does every week)?
>> Thanks.
>> PS( tulip version 0.92, kernel version 2.2.17)

This archive was generated by hypermail 2a24 : Fri Mar 30 2001 - 16:21:51 MST