RE: YDL and RealTekFE551 ethernet

Subject: RE: YDL and RealTekFE551 ethernet
From: Chris Ruprecht (
Date: Wed May 16 2001 - 06:22:30 MDT


As far as I know, the IP address to the NIC is assigned at boot time and
depends on your configuration. I went through this stuff about 2 weeks
ago on my RedHat box and I believe, YDL is very similar. What you need
to do is a:
netconfig [eth0]
where you can set the IP address or tell it to get one via DHCP. I did
this on my PB G3 and my old 9600 a while back but I use static IP
addresses in the 192.168.0 network.

What makes me extremely uncomfortable with the Network cards is the
dynamic assignment of the names (eth0, eth1, ...). I have 2 cards in my
RedHat machine, a 3Com 3C905 and a RT8139 based card. With kernel
2.2.17, which came with RedHat 7.0, both are seen at boot time, the RT
first, then the 3Com. After I built a new kernel (2.2.19 I think it was)
with IP firewalling installed, the RT was no longer detected and the
3Com became eth0. Now, nothing worked any more due to the fact that the
3Com is connected to the cable modem and the RT is connected to the
local LAN. It took about 4 hours to get the system back to where it was
before I started fiddling with all the stuff ... what a mess!

As to the system info which scrolls past to fast, have a look into

Best regards,

> -----Original Message-----
> From: Sean O. Denney []
> Sent: Wednesday, May 16, 2001 6:26 AM
> To:
> Subject: YDL and RealTekFE551 ethernet
> Hi everyone...
> It's been awhile since I've tried to get YDL on my old 6400/200, but I
> really need linux and I don't want to tie up my brand new computer
> with it.
> The problem i was having in the past was that the MacSense 10/100 NIC
> wan't being recognized by YDL, but it works fine in MacOS. So, until
> recently, my 6400/200 was a stand alone box (which, for linux, really
> sucks).
> I have recently come into some time to sit down and work at this
> problem. So here is what I did:
> 1. I found a discussion on this problem on the YDL mailing lists.
> 2. I found an install guide to build the rtl8139 driver into a module.
> 3. When I first boot linux, the hardware info scrolls by too fast for
> me to see any of it (If anyone know where this info is stored after
> boot, I would really appreciate it).
> 4. I do "ifconfig -a" but eth# is not listed.
> 5. I do "ifconfig eth0 up" and then eth0 is listed.
> Now, I'm not new to linux/unix, but when it comes to networking I'm
> not all too comfortable.
> My setup is as follows:
> DSL from BellSouth runs into a LinkSys Etherfast 4-Port DSL
> Switched Router. The local IP addressing is dynamic, so I will need
> YDL to obtain it's local IP from the router.
> My questions basically are:
> 1. How do I get YDL to obtain it's IP from the router?; and
> 2. What do I need to do once my NIC/YDL has obtained an IP?
> Any would would be greatly appreciated.
> Thanks in advance
> --- Sean Denney

This archive was generated by hypermail 2a24 : Wed May 16 2001 - 05:28:08 MDT