[SOLVED] Netatalk help

Subject: [SOLVED] Netatalk help
From: Sean O. Denney (sdenney@cise.ufl.edu)
Date: Sat May 26 2001 - 19:26:26 MDT

Thanks everyone for their help in trying to solve my problem. To
recap, the problem was as follows:


I have a StyleWriter 2400 which is connected to my Linux box (a
6400/200). Printing direct from linux was no biggie. The thing I was
trying to do was setup netatalk (atalkd, papd, afpd) so that i could
print from my G4/450MP via YDL.


The solution to the problem is as follows (remember you must be root
in order to do this-- SO DON"T SCREW UP ANYTHING!!):

1. Since AppleTalk support seems to not be compiled into YDL 1.2.1
kernel (which I didn't figure out until today), I added the following
line to my /etc/conf.modules file:

alias net-pf-5 appletalk

2. Since atalkd needed some help deciphering which interface to use
(lo or eth0 or ...), I added the following to my
/etc/atalk/atalkd.conf file:


[Make sure in the /etc/atalk/config file, that PAPD_RUN and
AFPD_RUN are set to "yes" (without quotes). Also make sure that
atalkd is being started in your run-level. Common sense stuff.]

3. Finally, this is what my /etc/atalk/papd.conf file looks like (sans

          :pr=|/usr/bin/lpd -Pstylps:op=netatalk:\

Now, for those of you who need a little help figuring out what this
means, here goes it (use one TAB for each indentation in the above):

"lpr-devil" is the name of the printer that will display in the MacOS
Chooser, you can put just about anything here, but i would personally
keep it short and without spaces or special characters.

"pr=|/usr/bin/lpd -Pstylps" is the print command that papd filters
incoming printjobs through. I read somewhere that piping the pr
directive works better than giving it a printcap printer name-- has
something to do with there being three separate printer job control
utilities (LPRng, lpd, and something else).

"op=netatalk" is the name of the operator for papd print jobs,
however, my printjobs seem to be owned by root and not netatalk. I
haven't delved into this yet, so I'll post a fix/reasoning about this
once i figure it out (right now, i think it might be because there is
no user netatalk).

"pd=/etc/atalk/ppds/APPLE230.PPD" is the location of the PPD
(postscript printer description) file that papd uses to communicate
between the MacOS LaserWriter INIT and lpd on YDL. I obtained the PPD
files from Adobe at the following location:


Now, when you unstuff these files, they are all in MacOS oriented
naming schemes (e.g. LaserWriter Personal 320). Now, the PPD I used
was named "LaserWriter", but in order for this file to function with
papd, you must rename it to it's 'PCFilename', which is:


Now, for sanity sakes, I decided to keep all the config files for
netatalk together, so I created a "ppds" directory in /etc/atalk/ and
then put the APPLE230.PPD file in this directory.

4. as root, I rebooted the linux box.

5. Once the linux box was up and running, I went into the MacOS
Chooser on my G4/450MP, select LaserWriter, waited a few seconds for
it to probe the local AppleTalk zone, and voila! A listing of the
printer, in my case "lpr-devil". I double clicked on "lpr-devil",
a prompt for the PPD file to use opened. I selected the button that
says "Generic". Once I did that, a desktop printer icon appeared.

6. I made a test print job, and it worked great. Make sure to go into
the Page Setup the first time and select the "US Letter Small" paper
size, or else it'll print outside the correct margins.


--- Sean Denney

This archive was generated by hypermail 2a24 : Sat May 26 2001 - 18:32:34 MDT