Re: Locating FAQ/help

Subject: Re: Locating FAQ/help
From: David C. Hacker (
Date: Mon May 28 2001 - 15:28:37 MDT

I never had any problem mounting hfs partitions. Even with the stock YDL
kernel. Just edit the /etc/fstab and /etc/mtab files and put int the partiion
information such as /dev/hda3 then the mount point. /mac or whatever you want.
make sure you have a directory created for the mount point. then put hfs for
the partition type. works fine. and will mount at startup.

On Mon, 28 May 2001, you wrote:
> On Mon, 28 May 2001, Michael Tucker wrote:
> > Although it may be a waste of time (because I am planning on getting YDL
> > 2 this week), I was wondering if someone has the URL of a good FAQ for
> > YDL/Mac-Specific Linuxes. I tried accessing the one maintained by Reid,
> > but my browser (IE) didn't seem to like it (that or there is no data in
> > the pages :). Specifically, I am trying to address two problems:
> I don't know of any good PPC-specific FAQs off the top of my head,
> but I was thinking of posting a little web diary about my adventures with
> Linux for PPC. I've been learning a stunning amount. For the time being,
> though, hanging out on the YDL and LinuxPPC mailing lists are doing me
> well.
> However, your first two questions don't really pertain to Linux on
> PPC specifically, but Linux in general. Here's a good place for general
> Linux topics:
> > 1) PPP doesn't work properly. I can use the PPP scripts (or ifup ppp0) to
> > dial out, but once connected I am unable to ping anything
> > successfully. I see the SD light (send) on my USR modem blink when I ping,
> > but I nothing happens with the RD light (receive). I've played with
> > different utilities to no avail.
> Check your /var/log/messages file and check if there's any useful
> debug text in there. Specifically, are you actually getting an IP address
> from your ISP? Use the tail command to see the last few lines of a
> file. Also, use -number to modify how many lines it spews out, for
> example:
> tail -30 /var/log/messages
> will show you the last 30 lines of the messages file. And you might need
> to be root to do that. There should be a bunch of lines that say what pppd
> is doing and a few of them should establish a remote and local IP
> address. If you don't see any lines with pppd, make sure that your pppd
> script is appending the parameter 'debug' on the pppd command line. Also,
> it should have the 'defaultroute' parameter as well, which tells the Linux
> TCP/IP stack to send all TCP/IP packets out through the modem by default.
> Also, here's the PPP HOWTO:
> > 2) I am not clear on what to do to set up basic services. Specifically,
> > when I was setting up the eth0 on my 8600, I initially went through
> > linuxconf. At that point I didn't know which driver to select (still
> > don't), but extensive web searching revealed that I should use netconfig
> > instead. I never would have guessed that on my own, and I'm not sure if
> > that implies that I am also using the wrong utilities to set up my
> > services (for example.... PPP?), so if there is a FAQ that addresses stuff
> > like that, it would be ENORMOUSLY useful if someone could direct me to it.
> Are you hooked up to another computer via ethernet so that you can
> test it once you think ethernet should be working? If so, first try
> bringing up the ethernet interface with a basic command line (do this as
> root):
> /sbin/ifconfig eth0 up
> If the command doesn't talk back to you, it likely worked. Type
> '/sbin/ifconfig' (doesn't have to be as root this time) and you should see
> a list of your TCP/IP interfaces including lo (loopback), eth0
> (ethernet) and ppp0 (if you managed to get that running and you're dialed
> in). If you connected to another computer, try pinging
> it. NOTE: is just a dummy address in this example. If you're
> on an actual network administered by someone else, you should find out
> what address to use instead. BTW, this all assumes that eth0 got brought
> up. Check your dmesg log to find out if that happened:
> dmesg | grep eth0
> Also, here's the Linux Networking HOWTO:
> > Otherwise, I am quite pleased with the setup, although there are a few
> > other things. For example, I have yet to successfully mount an HFS drive
> > in Linux, so I've been unable to compile and use my own kernels. I've
> > noticed some odd behavior when mounting an HFS floppy disk - namely,
> > copying files to it reported success, but didn;t copy any data (and then
> > caused my system to behave strangely). This was with the kernel that ships
> > with CS1.2.1
> Heh, another catch-22...:) I recently figured out how to mount HFS
> partitions, but until I did, I would transfer a new kernel to another
> computer via my ethernet LAN, reboot into MacOS, and then transfer the
> kernel back using a web browser. Tedious. I don't know if the stock YDL
> kernel has HFS support compiled in, but it doesn't come as a module. I
> don't think I remembered to test it before I managed to upgrade. Try this:
> mount -t hfs /dev/sda3 /mount_point
> /mount_point, of course is wherever you want it mounted, and /dev/sda3 may
> or may not be the right partition. If it doesn't recognize the hfs
> filesystem, then try to compile hfs as a module (you should have the YDL
> kernel source in /usr/src/linux-2.2.15/.
> Let us know how it all works out.
> --
> -Mike Melanson

David C. Hacker, DVM
923 B St #32
Schuyler, NE 68661
(402) 352-4248

-- David C. Hacker, DVM 923 B St #32 Schuyler, NE 68661 (402) 352-4248

This archive was generated by hypermail 2a24 : Mon May 28 2001 - 14:35:59 MDT