ppp still no joy

Subject: ppp still no joy
From: Scott Frankel (leknarf@pacbell.net)
Date: Sun Oct 28 2001 - 16:48:47 MST

I've followed Paul J. Lucas' web page for setting up ppp on my YDL2.0
PowerBook Pismo. Still no joy, though.

A command line invocation of the ppp daemon as root returns this error msg:

    pppd: This system lacks kernel support for PPP. This could be because
    the PPP kernel module could not be loaded, or because PPP was not
    included in the kernel configuration. If PPP was included as a
    module, try `/sbin/modprobe -v ppp'. If that fails, check t
    [root@flaquito papi]# [FAILED]

This after compiling a new kernel from the 2.4.8 source, making sure that
the ppp flags were turned on in the .config file (also as per
his web pages).
The kernel build appears to have worked without error; in fact, I'm running
it now. And the modprobe gag didn't return anything useful either.

Some questions:
- my /boot dir now contains links to the new vmlinux and System.map files
  created during the kernel build. What should the module-info, zImage-chrp,
  and zImage-prep point to? Currently, they point to what they pointed to
  before my build: 2.4.8-0.4c files.

- if I'm pointing to invalid module-info or zImage files, how does one create
  new, valid ones?

- I've tried kernel builds with CONFIG_SERIAL and CONFIG_PPP flags in
  .config set to "m", and another with these flags set to "y." I've gotten
  identical, no joy results from either modules or compiled right in the
  kernel. Is one method preferred over the other?

What else should I check? Thanks in advance!

p.s. I want ppp support so I can connect an Agenda pda to my PowerBook.
In addition, I also need support for the Keyspan Serial<->USB converter as
well. I believe I've set the proper flags in .config for that.

I know you're gonna suggest I go directly to IR ;) Can't do that until I
upgrade the Agenda's OS. Once with cables, IR after that.

I've created an /etc/ppp/peers/agenda.vr3 file with what I believe are
proper parameters set. The command line invocation I've been using to
test if ppp works is (as root):

    % . /etc/rc.d/init.d/functions
    % daemon pppd call agenda.vr3

Anything else?

This archive was generated by hypermail 2a24 : Sun Oct 28 2001 - 16:01:01 MST