Re: eazel nautilus make attempt

Subject: Re: eazel nautilus make attempt
From: goo (
Date: Mon Sep 04 2000 - 14:33:05 MDT

> All the preceding packages seemed to compile fine (gtkhtml would have liked
> the
> pspell package to have been installed, but did fine without it). When I tried
> to
> make nautilus, I got the following errors before quitting:
> glibwww-init.o: In function `glibwww_init':
> /root/Desktop/eazel/nautilus-0.1.0/components/html/glibwww-init.c:114:
> undefined reference to `HTZLib_inflate'
> /root/Desktop/eazel/nautilus-0.1.0/components/html/glibwww-init.c:114:
> undefined reference to `HTZLib_inflate'
> collect2: ld returned 1 exit status
> make[3]: *** [ntl-web-browser] Error 1
> make[3]: Leaving directory
> `/root/Desktop/eazel/nautilus-0.1.0/components/html'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/root/Desktop/eazel/nautilus-0.1.0/components'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/root/Desktop/eazel/nautilus-0.1.0'
> make: *** [all-recursive-am] Error 2

You're actually very close! I was doing this on an x86 system while
XFree86, Gnome, etc. were all building on my PPC (they built faster on my
Athlon). I ran into the same problem, but if you search for HTZLib_inflate
on Google, you'll find a source file HTZip.c which contains the routine(s)
you need. Then if you search for that file, you'll find it in the libwww
source! (w3c-libwww-5.2.8/Library/src/HTZip.c) The only missing link is
sysdep.h, which looks like it should be in the libwww source, but isn't.

I've got it on my web server, though:

I pulled it off a web site and had to edit a little extra HTML crap out, so
I can't guarantee anything, but if you have problems with it you can always
get it off a Google search.

> Also: when the ./configure was done for Nautilus, it claimed I didn't have
> Mozilla installed (mozilla is needed for browsing capability in nautilus) even
> though I do (M17). This may be because of the devel package it needs?

Don't worry about that for can always modify the configure script
to "recognize" Mozilla.

> If anyone gets this to work OK (goo?), I'd sure like to know about it. Please
> keep me posted.

I'm actually surprised you got that far as painlessly as you did. I had
newer versions of some of the Gnome components, and ran across a few pieces
of code that needed updating. I also had to patch the configure files for
all those packages you built so they'd recognize that I had gnome-vfs


This archive was generated by hypermail 2a24 : Mon Sep 04 2000 - 14:39:04 MDT