Re: YDL 1.2 server, new G4, no usb keyboard response

Subject: Re: YDL 1.2 server, new G4, no usb keyboard response
Date: Fri Sep 29 2000 - 10:14:23 MDT

I have yaboot.tbxi, yaboot.conf, ramdisk-image.gz, vmlinux, and
vmlinux-2.2.17pre20-ben3.gz all on the mac partition. I just tried Ben's
pre20 kernel with the YDL 1.2 ramdisk which didn't work. I guess the
ramdisk has to match the kernel it was built for.???? I don't think this is
a yaboot problem, it seems to work just fine. I believe this is a kernel

Thanks John

"William F. Hostman" <> on 09/28/2000 11:32:30 PM

Please respond to


Subject: YDL 1.2 server, new G4, no usb keyboard response

Did you move the ramdisk.image.gz file to the same location as yaboot and
the kernel?

the ramdisk.image.gz from the cd works OK. But it really needs to be with
the kernel image. And it really helps if yaboot is on the same partition
too, but not essential.

If not, do so and edit the yaboot.config to point to them all in the same

If that fails, it's probably a kernel problem. Also, keep in mind that
you'll need to pop over to the command-line window during package installs
and do the backport-enabling bit (it is documented on BenH's page, but you
may not see the link as being obvious, so keep trying til you find it. It
starts with rm mouse and rm usbmouse, then a mkdir, a mknod, and two ln
commands. I did it after the dev package, don't do it before, or the
package will overwrite parts of it...), and thus was able to get both
mouseconfig and xconfigurator to be happy. (I still had to edit a few
files... I'll put my changes list up at so you can see all the points
where I had to moify stuff to make YDL happy. Hope this helps.

>Hi all,
>we have a new G4 with usb keyboard, mouse and zip drive along with YDL 1.2
>champion server. We have a minimal installation of the MAC OS still
>installed. I can boot from the CD and things load fine. I can see the
>'loading kernel ...' message and console messages scroll by. I noted some
>usb: ... assigned device no # 1
>usbcore: usb devise not responding, giving up ( error = -101)
>hda:hda: lost interrupt
>These don't seem like a good omen, but the kernel loads and we get to the
>YDL installation screens. Yeah. BUT the keyboard does not work. I have
>tried to unplug it and plug it back in but nothing seems to work. I have
>tried moving the ramdisk and vmlinux images to the MAC partition and boot
>using the infamous 'boot hd:,yaboot.tbxi' . I'm not sure why I don't have
>to specify a partition number but the loader does it's job and I see
>loading kernel ..... . The kernel loads and I see the same console
>so I expect trouble and I get to the same spot at the beginning of RH
>installer program and the keyboard won't work.
>I keep reading about benh's kernel so I replaced the vmlinux from YDL 1.2
>that I moved to the MAC partition with vmlinux-2.2.17pre20-ben3.gz but it
>seems to crash during the loading kernel.... part. Does it require a
>complimentary ramdisk image to work correctly????
>I've also read about the boot loader associated with the lost interrupt
>errors that we are seeing but I don't understand how a boot loader would
>involved there. yaboot has done it's job the kernel was found and loaded.
>Oh well.
>I would appreciate any help that I could get. We have a cd burner in our
>labs so I could try lots of different things.

William F. Hostman | "Smith & Wesson: THe original Point and Click
Aramis 0602 C55A364-C S kk+ as+ hi+ dr+ va++(--) so+ zh++ vi+ da++ sy- ge-
533 Vilani: uilamaanamti
IMTU 1.0: tc tm++ tn- t4-- tt+ to- tg-- ru+ ge 3i+ c+ jt-() au+ st- ls
pi+() ta+ he+(-) kk+ as+ hi+ dr+ va++(--) so+ zh++ vi+ da++ sy- ge- pi+

This archive was generated by hypermail 2a24 : Fri Sep 29 2000 - 10:18:09 MDT