Problem with /bin/login?

William R. Dickson (
Sat, 5 Jun 1999 15:14:08 -0700

Hi all,

I've been trying to get my YDL box set up for incoming dialup on a single
modem connected to ttyS0, using mgetty. The modem answers, and I get a
login prompt, I type my login and hit return, then nothing else. mgetty
documentation indicates that this can sometimes be a problem with DCD on
modems, and that the init string must be adjusted to keep the DCD high. I
tried this with no effect.

I tried a null modem connection, with the same results.

On a whim, I tried running /bin/login from my shell prompt. My session was
terminated. I tried it again from the console. _That_ session was

So I ran strace on /bin/login, and got about a thousand lines that look
like this:

close(1023) = -1 EBADF (Bad file descriptor)

...and a block at the end that looks like this:

close(5) = -1 EBADF (Bad file descriptor)
close(4) = -1 EBADF (Bad file descriptor)
close(3) = 0
ioctl(0, 0x402c7413, 0x7fffc718) = 0
brk(0) = 0x1845000
brk(0x1847000) = 0x1847000
readlink("/proc/self/fd/0", "/dev/ttyp0", 4095) = 11
setpgid(0, 0) = 0
ioctl(0, 0x402c7413, 0x7fffc988) = 0
socket(0x18446b8 /* PF_??? */, 0 /* SOCK_??? */, 0) = 0
chmod("/dev/ttyp0", 0622) = 0
ioctl(0, 0x802c7416, 0x7fffca58) = ? ERESTARTSYS (To be restarted)

(this trace was run from a telnet session, not the console -- I could do
one from the console if anybody thinks it'll make any difference.)

So, is there something wrong with /bin/login, or have I made a mistake myself?



 William R. Dickson -- Consuming the Earth's limited resources since 1968   < >   < >   ICQ: 14117523

I don't want to achieve immortality through my work. I want to achieve it through not dying. -Woody Allen

This archive was generated by hypermail 2.0b3 on Wed Jun 30 1999 - 11:30:07 MDT