Fwd: iMac Help!

Subject: Fwd: iMac Help!
From: Shawn A. Wilson (YzfRacer@erie.net)
Date: Tue Nov 30 1999 - 22:11:54 MST

Gene, ive sent your questions over the lists i know there were a few changes in
the Rev.D's and i dont know what and how to deal with them, im sure the fine
folks over these lists do however =)


---------- Forwarded Message ----------
Subject: iMac Help!
Date: Tue, 30 Nov 1999 22:31:00 -0600 (CST)
From: Gene <gct1@ritz.cec.wustl.edu>


I'm trying to install Yellow Dog on a Rev D 333 iMac, and I'm running into
some problems. I'm running 8.6; I did the initial partitioning with Drive
Setup and the subsequent partitioning with pdisk.

I manage to make it all the way through the installer, but when I try to
boot into Linux without the ramdisk, it gets through a lot of the boot
process. Right after it checks all the partitions, I get the following

request_module [ block_major_8] : root fs not mounted
VFS - cannot open root device 08:01
kernel panic: vfs: unalbe to mount root device 08:01

I've tried both CD installs and ftp installs. I'm using the Rev 1 Blue G3
kernel found at www.linuxppc.com/hardware page.

I'm running off an IBM Deskstar 18 gig drive; I thought the problem was
that my root partion was too high in the block numbers to mount, but then
I reformatted my drive and made the root partition the first one. It
starts at block 704. But it gives me the same error whether I format the
partition with root as the first partition or the sixth.

do you have any advice? Can you point me to somewhere I can find the
right answer? I'd really like to get this running, or finally figure out
that I can't run it. One way or the other, I want some "closure."

--Gene Tien

This archive was generated by hypermail 2a24 : Fri Dec 03 1999 - 19:07:33 MST