Runlevel 1 & root

Subject: Runlevel 1 & root
From: Jim Cole (
Date: Fri Oct 08 1999 - 00:45:34 MDT

So, after a PPP/Netscape hang ended up toasting my filesystem, the next
boot wimped out and told me I needed to do the runlevel 1 & fsck thing to
to clean up the mess. But logging in to do so was not possible since the
system no longer considered my root password to be valid. I was not
entirely surprised since this same issue has shown up on the list in the
past. However, I thought it was supposed to be fixed with one of the
update packages? Not so in my case; I have all updates applied. Is there
some other fix for this problem?

I did eventually figure out from the archives that an "init=/bin/bash"
will get you into single user mode, however this had a problem of its own.
After running fsck to clean up the filesystem, I tried to reboot, but got
a message saying /etc/initrunlvl could not be written. Doh! So I remounted
the partition read/write. But when I tried to do a shutdown -h/-r or
reboot the system just sat there for a second and gave me back a prompt. A
three finger salute also failed. A control D just hung the system. So,
after finally getting in and fixing the filesystem, there was no way to
get back out without corrupting it again. Finally, I resorted to doing a
sync; mount -r -o remount /dev/hda? and turning the machine off. Not
clean, not good, but it at least got me out with being forced back into
single user mode to again fix a filesystem that I would have to corrupt to
get back out *sigh* Is there some secret for getting a clean exit from
single user mode after going in with init=/bin/bash?

Another small thing I noticed during this adventure is that mount/mtab
show the root partition as mounted read/write even when it is mounted


This archive was generated by hypermail 2a24 : Tue Nov 02 1999 - 16:20:57 MST