Re: Kernel 2.2.12

Subject: Re: Kernel 2.2.12
From: jingai (
Date: Sat Oct 09 1999 - 21:05:00 MDT

>We have Contour mice running on most of our machines on this kernel
>I haven't yet provided a new mouseconfig program.. so for the time
>being... run mouseconfig and select "Microsoft IntelliMouse (PS/2)"
>(this is the type of mouse that usb mice should be set to)..

I did this. Just so you know, I have a UMAX S900 with an Entrega 4-port
USB card (I also tried it with a Belkin BusPort card).

>However, since you're using mouseconfig that shipped with 1.1 that just
>sets things up for the old USB system, you'll need to remove /dev/mouse
>and make sure things are setup as follows:
>/dev/mouse is a symlink to /dev/usbmouse
>/dev/usbmouse is a symlink to /dev/hidbp-mse-0
>After you've done this, restart gpm or X.. and your mouse should work!

I did this too. Trouble is, the OHCI driver doesn't register mouse
clicks/movement. It registers key presses fine, though. This is
basically what I am doing to test it: Click the mouse buttons a few
times, and then I do a procinfo. The number doesn't increase, but it
does increase when I press keys on the USB keyboard. I had exactly the
same behavior with the Belkin card.

FWIW, you may want to put this on your FAQ: With the UMAX S900 (and
possibly other Macs with two PCI buses), you have to place the USB card
in one of the first three slots (on the bus 0). The driver doesn't like
recognize anything but the card itself if it's placed in one of the last
three slots (bus 1). This is actually what made it work -- it just so
happened that I had also tried the new kernel you posted simultaneously..
 however, my 2.3.19 kernel and my own hacked-up 2.2.12 kernel both work
as well, with the exception of the mouse.

Any ideas? (BTW, the mouse and keyboard work fine in MacOS, so nothing
is wrong with them, or the card)


This archive was generated by hypermail 2a24 : Tue Nov 02 1999 - 16:20:57 MST