Kensington mouseworks USB mouse mostly works

Subject: Kensington mouseworks USB mouse mostly works
From: Tom Pollard (
Date: Sun Oct 17 1999 - 21:17:57 MDT


Last week I finally picked up a Kensington Mouseworks 4-button USB wheel
mouse for my G3 powerbook and have been having some problems getting it
configured the way I want it. I'm using Hugh Caley's 2.2.13 kernel and
XF68fb_dev and tried setting up gpm to let me use both the trackpad and
the mouse, but couldn't get it to work. However, I can use the mouse by

    Protocol "IMPS/2"
    Device "/dev/usbmouse"
    Buttons 6

in the Pointer section of XF86config. The problem is that two of the four
buttons aren't recognized. The first button, wheel and last button are
recognized as buttons 1, 2 and 3, but the two middle buttons don't
register at all. They don't generate button events in xev. They do
generate interrupts according to /proc/interrupts. Is there any thing I
can do to get them recognized? I'd really like to be able to use the
second, third and fourth buttons as buttons 1, 2 and 3.

I tried all of the other *PS/2 protocols in XF86config, but none besides
IMPS/2 worked with this mouse. Any advice would be gratefully


W. Thomas Pollard Schrodinger, Inc.

This archive was generated by hypermail 2a24 : Tue Nov 02 1999 - 16:20:58 MST