Re: YDL 1.2 on new G4

Subject: Re: YDL 1.2 on new G4
From: Tim Duty (
Date: Tue Apr 18 2000 - 20:56:38 MDT

 OK, I obtained the XServer and files from
and now X is working beautifully at 24bpp. A couple of notes regarding

1) xf400_r128.tar.gz contains subdirs etc,bin, and lib. etc contains
only etc/X11/XF86config, a sample configuration file. bin and lib need to
go into /usr/X11R6.

2) The provided XF86Config file is for an Apple Studio 17" monitor and
doesn't work for my 19" Sony G400. To get it to work, I made the changes
(from the monitor manual)

    Identifier "Sony G400"

     HorizSync 30-107
    VertRefresh 48-120

and commented out all of the mode entries, e.g.

#Mode "1024x768"
    # D: 78.746 MHz, H: 60.020 kHz, V: 75.025 Hz
# DotClock 78.747
# HTimings 1024 1056 1152 1312
# VTimings 768 769 772 800
# Flags "+HSync" "+VSync"

If I knew more about what I was doing, I could probably figure out correct
settings for these entries??

Finally I used a Screen section as follows

Section "Screen"
    Identifier "Screen 1"
    Device "r128"
    Monitor "Sony G400"
    DefaultDepth 24
    Option "BackingStore"
    Subsection "Display"
        Depth 24
        Modes "1280x1024"
        ViewPort 0 0

            Thanks Jim for the pointer.

Jim Cole wrote:

> Tim Duty's bits of Sun, 16 Apr 2000 translated to:
> > I was successful in installing YDL 1.2 on a new G4 450, but it was
> >not easy. First of all, no version of BootX worked...and I tried them
> >all. Second, the documentation is a little weak on using yaboot. I
> >finally figured out that I need to use 'hd:5,\yaboot.tbxi ' . I
> >determined this by using fdisk during the install to find out where
> >MacOS was on the first drive (I have Linux installed on a second
> >drive). The only way for me to boot now is to go into open firmware
> >(i.e. alt-command O-F) and type 'boot hd:5.\yaboot.tbxi'.
> As you found, BootX doesn't work with the new G4's. The newest version
> of the YDL installation manual mentions this. It also includes some
> documentation on setting up with yaboot. In addition to the yaboot.tbxi
> approach, it also includes the script and setup for achieving a bit
> more friendly dual boot setup; one where you can hold down the space
> bar, or not, to choose your OS.
> >#1 problem:
> > I can only get 8-bit resolution from the X-server, at a
> >noticeably low refresh rate. This is really hard on the eyes,
> >especially the refresh rate---gives me a nasty headache. Does anyone
> >know if there is a better X-server out there? I tried Xpmac.rev10, but
> >it doesn't work on my system.
> Again, a new G4 thing. The Rage 128 Pro cards are not fully supported
> just yet, but they are working on it. If you can't/don't want to wait for
> something official, you can get X working nicely with a kernel patch
> and modified X server. There is a lot of info in the archives on the
> subject of the new G4's, since a number of us just went through this ;)
> Unless the fixes have made it into farther into the main stream,
> is the place to go for the
> patches and X server.
> >minor problem: .Xdefaults file doesn't seem to do anything. This is
> >usually where I put things like
> >
> > emacs.background: black
> > emacs.foreground: lightgray
> > etc....
> > This file didn't exist, so I created it, but it apparently
> >doesn't get read.
> Have you tried .Xresources instead? I believe that is what .xinitrc
> reads in by default.
> Jim

This archive was generated by hypermail 2a24 : Sun Apr 23 2000 - 22:14:40 MDT