serious appletalk permissions problem

Subject: serious appletalk permissions problem
From: Stefan Jeglinski (
Date: Tue Jul 25 2000 - 14:00:14 MDT

I have a user "webmaster" in the home directory that belongs to a
group "groupname". The way this is structured directory-wise is:

    | +
    | |
    | |
    | +---/www -> /home/httpd/html (symbolic link)

The user "webmaster" is maintaining the site running on Linux and is
using BBEdit (Mac) to edit pages. In the past with a LinuxPPC install
this worked fine: the webmaster mounted the "webmaster" volume on her
desktop and opened the www folder (a symbolic link to the real
content), did editing, copying, or deleting, and all was well.

I have a new YDL1.2 install and am trying to set up the same thing.
But I have an interesting breakage of the method. After the volume
"webmaster" is mounted on the Mac desktop:

1. The webmaster can copy a file or a folder to /webmaster.

2. The webmaster -cannot- copy a file into /www (write permission failure).

3. The webmaster -cannot- edit a file in /www (write permission failure).

4. The webmaster -can- copy an entire folder of content into /www.

5. The webmaster can take the same file that won't write or edit, move
        it into a folder on her desktop, and copy the folder to /www with no
        error as per #4. That file -can- then be opened over the network and

In trying to track this thing from a permissions standpoint, I have
gone so far as to change the owner (to webmaster) and group (to
groupname) of every directory and file from /home on down to the
individual files in /html. Likewise for /webmaster directory. I note
that the symbolic link has 777 permission. Same result every time.

What am I missing here? In particular, how is it that webmaster can
copy an entire folder into /www but not a single file? And how is it
that the file can be hidden in a folder and snuck into /www that way?

Totally perplexed,

Stefan Jeglinski

This archive was generated by hypermail 2a24 : Tue Jul 25 2000 - 14:04:35 MDT